编辑WordPress主题的 functions.php 文件的注意事项

创造未来
创造未来
创造未来
686
文章
0
评论
2017年8月4日23:07:50编辑WordPress主题的 functions.php 文件的注意事项已关闭评论 已被17 人盯上 1998字阅读6分39秒

WordPress大学 很多教程都提到“将代码添加到主题的 functions.php 文件”,但总有些新手朋友总是反馈说:如何添加?添加后出错?添加后网站就不能访问啦……所以今天就来说说编辑 functions.php 文件应该注意哪些问题。

functions.php 有什么用

functions.php 是 WordPress 预留的功能函数文件,专门用于添加各种自定义函数代码。现在的WordPress主题的功能越来越强大了,一般都自带了 functions.php 这个文件(通常在主题根目录)。

php中的注释

注释,就是专门用来对代码进行补充说明的文本,一般分为单行注释和多行注释,单行注释使用两个斜杠 // ,多行注释使用 /* */,示例:

<?php
/**
 * 这是多行注释
 * 注释2行
 */
function hello_world() {
	// 单行注释
	// 再注释一行
	echo "<p>Hello World!</p>";
}
?>

php代码应该添加到 <?php  和 ?> 之间

打开 functions.php 文件,你会发现,文件开头一般都是 <?php ,表明这个文件是遵循php代码规范的,你需要将函数代码添加到它的里面,比如:

<?php
//开始php语法
 
function hello_world() {
	echo "<p>Hello World!</p>";
}
 
//结束php语法
?>

避免 <?php 和 ?> 多重嵌套

在 <?php 和 ?> 之间,不要再添加 <?php 和 ?>,如下面的例子就是错误的:

<?php
//开始php语法
 
<?php //错误:嵌套啦
 
function hello_world() {
	echo "<p>Hello World!</p>";
}
 
?>

可以看到,第一个 <?php 没有结束,又嵌套了一个 <?php ,这样的后果就是导致部分 php 代码失效,严重的可能会导致网站崩溃。

不要在 <?php 和 ?> 之间直接添加其他语种代码

<?php 和 ?> 之间的代码应该符合php语言规范,你不可以直接在他们之间直接添加其他语种代码,比如以下几种错误类型:

<?php
 
//错误1:直接添加文本
Hello World!
 
//错误2:直接添加html代码
<div><p>Hello World!</p></div>
 
//错误3:直接添加js代码
<script type="text/javascript">
	$(document).ready(function() {
		$("a.anchorLink").anchorAnimate()
	});
</script>
 
//错误4:直接添加css代码
<style type="text/css" media="screen">
	.textComment{
		display: inline;
	}
</style>
 
?>

可能有些朋友会说,为什么我看到有些人可以添加html代码?比如下面代码的第 5 行:

<?php
function hello_world() {
	echo "<p>Hello World!</p>";
?>
	<div><p>Hello World!</p></div>
<?php
}
?>

其实这是php和html混排,HTML代码并没有直接添加在 <?php 和 ?> 之间,你可以看到 第 4 行结束php语法,第 6 行重新开始 php语法,这种写法是合法的。

注意字符转义

网络上很多代码由于没有使用代码高亮插件,可能会导致代码中的某些字符发生转义,或其他错误。比如:

半角符号变成全角符号:引号、逗号、句号、冒号、括号、分号等

常见的转义:< 变成 &lt;> 变成 &gt;& 变成 &amp;

注意php文件的编码

WordPress 是使用 utf-8 格式编码的php程序,utf-8编码又分为 含BOM 和 无BOM 两种,由于我们很可能在 php 文件中添加了中文,所以建议保存 functions.php 等php文件为 Utf-8 无 BOM 格式。否则,很可能会出现 网站空白、布局错乱、出现异常文字 等问题。

使用专业的代码编辑工具

强烈建议大家使用专业一点的代码编辑工具,比如 Notepad++、Sublime Text、EditPlus、DreamWeaver等,使用这类工具的好处:支持代码高亮、代码纠错提示、快捷插入代码片段、支持选择编码类型等等。

特别提示不要使用微软自带的 txt记事本编辑器 来编辑 php 文件!!很可能会导致代码错误、编码错误等问题!!很多 FTP软件默认也是调用 txt记事本编辑器的 ,需要注意。

最后,建议大家学习一下 php编程入门,至少简单了解一下基本的语句用法,比如 if、echo 等。还有不建议直接在functions.php里修改,将你自己要添加到 functions.php 的所有代码,添加到主题根目录的 ziji-functions.php(文件名自己起),然后在functions.php中添加

include (TEMPLATEPATH . '/ziji-functions.php');

即可

继续阅读
weinxin
我的微信
这是我的微信扫一扫
  • 本文由 发表于 2017年8月4日23:07:50
  • 除非特殊声明,本站文章均为网络收集,如侵犯您的权益可联系邮箱:541074440@qq.com
WordPress 4.9 正式版发布 WordPress资讯

WordPress 4.9 正式版发布

WordPress 4.9 正式版已发布,它能让您的设计工作流更顺滑,防止您的代码出现错误。不过呢小编我发现了部分英文还没被翻译成中文,而且编辑器里的清除超链接的按钮也没有了。主题预览有些卡顿。 大规模的定制器改善、代码错误检查和更多! 欢迎来到改良的定制器工作流,包括了设计草稿、锁、计划和预览链接等新功能。此外,代码语法高亮和错误检查能让您的站点建设体验更整洁平滑。我们还为您带来了全新画廊小工具...
2017年7款最好用的 WordPress 多语言翻译插件 Wordpress插件

2017年7款最好用的 WordPress 多语言翻译插件

写一篇好文章,通常要做大量工作,你自然就想把写出来的文章分享给最广大的受众。 现而今,最通用的语言当属英语。Ethnologue(民族语言网)在其2015年版用户手册中指出,在全球74亿人中,有近10亿人以某种形式说英语,有4亿人以英语为母语。 与使用互联网有关的数据则更加有趣。网络技术调查网站W3Techs公司的调查结果表明,虽然仅有25.9%的互联网用户说英语,但是多半,准确地说,53.6%的...
WordPress 4.8.3 安全更新 WordPress资讯

WordPress 4.8.3 安全更新

WordPress 4.8.3 是一个安全版本,主要修复之前版本存在的安全问题: 之前版本的 $wpdb->prepare()  可以创建意想不到的和不安全的查询,导致潜在的SQL注入。WordPress 核心并没有直接受到这个问题的攻击,但是我们已经添加了增强功能来防止插件和主题意外地造成漏洞。 此外,WordPress 4.8.3 还包含的  esc_sql()  函数的行为变化。大多数...
美化文章标题和内容--WordPress集成有字库字体插件 Wordpress插件

美化文章标题和内容–WordPress集成有字库字体插件

有字库简介 有字库是全球第一中文Web Font(网络字体)服务平台。 我们致力于美化网页界面,降低网页设计和维护的难度,同时提升效率。 Web Font 的服务在国外已经比较普及, 著名的有Google Fonts、Typekit等网站,但是国内在中文Web Font上面一直是一片空白,众多中文网站设计者们只能望洋兴叹。 有字库为此应运而生。 在正式介绍插件以前,先来普及下有字库能够干什么,换句...